Page MenuHome

Checkbox labels don't highlight on mouse-over in popovers
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1660/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 446.14

Blender Version
Broken: version: Since 2.80

Exact steps for others to reproduce the error

  1. Click on the Viewport Overlays dropdown.
  2. Hover over the 'Statics' label. As the checkbox is unchecked this label should hightlight when hovering over it.

Event Timeline

Hans Goudey (HooglyBoogly) changed the task status from Needs Triage to Needs Information from User.Jun 29 2020, 10:58 PM

Thanks for the report. I can't reproduce this though. What version are you using?

For me, when turned off, the "Statistics" checkbox gets slightly brighter when I mouse over it.

If you pick any unchecked box in the Preferences Editor or the Properties Editor and you hover over either the unchecked box or the label, BOTH the label and unchecked box will get slighlty brighter.

If you do the same action, as mentioned in the Viewport Overlays ONLY the unchecked box will get slightly brighter. The label will remain unhighlighted.

Ah, of course, I see what you mean. Looks like an issue with checkboxes in popovers

Is this still an issue? I can't seem to reproduce this or I am looking at wrong thing

Hans Goudey (HooglyBoogly) triaged this task as Low priority.Jul 30 2020, 8:41 PM
Hans Goudey (HooglyBoogly) changed the subtype of this task from "Report" to "Bug".

Yes, in a popover checkbox labels don't highlight when you hover over them.

Hans Goudey (HooglyBoogly) changed the task status from Needs Information from User to Confirmed.Jul 30 2020, 8:41 PM
Hans Goudey (HooglyBoogly) renamed this task from UI Bug: Unchecked box, label highlighting fails in various drop downs (Viewport Visitibility dropdowns as an example). to Checkbox labels don't highlight on mouse-over in popovers.Aug 3 2020, 4:34 AM