Page MenuHome

Annotation does not show in Sculpt Mode.
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: AMD Radeon(TM) RX Vega 10 Graphics ATI Technologies Inc. 4.5.13558 Core Profile Context 26.20.11016.6002

Blender Version
Broken: version: 2.90.0, branch: master, commit date: 2020-08-31 11:26, hash: rB0330d1af29c0
Worked: (newest version of Blender that worked as expected)

Short description of error
Annotation does not show in Sculpt Mode, but the icon of the tool is there to use. You have to go back to Layout Mode (or window) to be able to see it.

Exact steps for others to reproduce the error
Hi, I was just trying the new sculpt features and testing all the icons, everything worked except for the annotation tool. I don't know if it's a bug or it's been coded that way or not but if you can't see the annotation in sculpt mode, why bother to put there the icon? right? If I'm on the sculpt mode (and the sculpt panel), switching to edit mode or object mode doesn't show the annotation eather.

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Sep 1 2020, 2:06 PM

In the Sculpting workspace, you need to enable Annotations in the Overlay popup

Does this work for you?

@Pablo Dobarro (pablodp606) : it is a bit of a weird choice to have them disabled by default?

Ok, sorry for the trouble, it worked! I didn't know that it had to be activated in the overlays.

I agree with you @Philipp Oeser (lichtwerk), if you don't know (as me) that is hidden, people may think it is broken.

Thanks!

Philipp Oeser (lichtwerk) closed this task as Archived.Sep 2 2020, 2:22 PM
Philipp Oeser (lichtwerk) claimed this task.

OK, will close for now (since it is not really a bug), but I am still uncertain why this is disabled for sculpting.

CC @Pablo Vazquez (pablovazquez)
CC @William Reynish (billreynish)
CC @Julien Kaspar (JulienKaspar)

We could enable the overlay option in the template. Not sure if we can merge this with T82273

Antonio Vazquez (antoniov) changed the task status from Archived to Resolved.Nov 4 2020, 4:16 PM

Fixed with commit abc5e7d59600

Antonio Vazquez (antoniov) changed the subtype of this task from "Report" to "Known Issue".Nov 4 2020, 4:17 PM