Page MenuHome

Cuda device not found starting blender 2.82, cycle completely disabled
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.7.0-1-amd64-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: AMD TAHITI (DRM 2.50.0, 5.7.0-1-amd64, LLVM 10.0.1) X.Org 4.5 (Core Profile) Mesa 20.1.6

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: version: 2.81 (sub 16), branch: master, commit date: 2019-12-04 11:32, hash: f1aa4d18d49d, type: Release

Short description of error
From 2.82 (on 2.82a, 2.90 and up to the daily build), my GPU (GTX1060) isn't seen in the preferences and Cycle rendering is absent from the list of available engines.

Exact steps for others to reproduce the error
Upon starting blender, going into Edit > preferences > system shows an empty "Cycles Render Devices". Neither cpu nor gpu, ...
Render properties > Render engine only lists Eevee and workbench.

On previous versions (up to 2.81a), the GPU is listed and Cycles is available as rendering engine.

The system info from 2.82 seems to imply that the GPU was properly detected :

Thanks in advance.

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Needs Information from User.Sep 19 2020, 1:00 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

Cycles going missing suggests Blender was built without Cycles, and Blender without Cycles will naturally leads to no CUDA.

Please try downloading Blender from the official website and report back with results (https://www.blender.org/download/). Blender downloaded from other places, such as the package manager integrated into your distrobution may be missing features.

I've only been using Blender from the official website.
Just now, I tested with the 2.90.1 version (from https://www.blender.org/download/Blender2.90/blender-2.90.1-linux64.tar.xz ) and the problem is still present.
Can I provide more info on how to understand the issue?

Maybe you accedentially disabled the Cycles add-on. Try this, select from the top of Blender File -> Default -> Load Factory Defaults and see if that helps.

You're right, that was it.
I had no clue it could be disabled, nor how I did so.
Thanks a lot!

Alaska (Alaska) closed this task as Resolved.Sep 26 2020, 5:36 AM
Alaska (Alaska) claimed this task.

Marking this report as resolved.

To save the default settings for Blender so they persist when you re-open Blender, follow these steps:

  1. Load factory defaults by selecting from the top of Blender File -> Default -> Load Factory Defaults
  2. Save the user preferences by selecting from the top of Blender Edit -> Preferences then selecting the Save Preferences button in the bottom left.