Page MenuHome

random weight painting keep appearing even after I removed them
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVIDIA RTX 2070

Blender Version
I use 2.90.1

Short description of error
When weight painting, new random weights appear. Even after removing them, they come back, especially when changing between pose position and rest position.

Exact steps for others to reproduce the error
Trying to make better the automatic weight painting that was generated, random weights show up for each bone. I manually remove them, but they still come back what ever I do.
On the file that I attached:
put 'show weight contour to see it better'.
Check the weight painting of the shirt. There are weights in very unexpected places, especially on the opposite symmetric side of each bone.
You can remove those weights (but sometimes it's impossible), but if you switch between pose position and rest position, new random weight will come back, more or less in the same spots.

Am I the only one who gets that?

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Oct 5 2020, 4:57 PM

Having a hard time reproducing, but might be me not being a rigger.

Could you elaborate a bit more?

  • which bone should be selected, which weights to paint out?
  • maybe screenshots would help, or a screenrecording?

Also: do you have issues in previous versions as well?
https://www.blender.org/download/lts/

Hello Philipp,

Yes my description is very poor... sorry :)

I just spent an hour trying to reproduce the bug but I can't redo it indeed.
I have been stuck for several days with that last week.

If I remember well, it was happening like that:
first you should turn on the 'show weight contours' in the overlay.
If you select the rig and the shirt you can edit the weight paint by going in the weight paint mode.
If you then select the left shoulder bone you'll see weight paintings where you would expect them, but also on the right side, rather discreet ones. (it also worked with the hip bones and upper arms bones left and right)

Well, those were impossible to remove, even after I applied the mirror modifier.
I would remove them but then, when I switched between pose position and rest position they would come back more or less at the same position.

On the full rigging that I use in my project, those weight paintings stopped to come back at some point I am not sure when/how because I tried so many times.

Also, I first had the problem on blender 2.90, when I switched to 2.90.1 it felt different, I first thought that the bug was gone but it wasn't. Maybe something still got fixed between 2.90 and 2.90.1.

I had a discussion to find help, on Blender StackExchange, you can see a picture:
https://blender.stackexchange.com/questions/195818/weird-symetry-in-the-weight-painting-after-automatic-weight-painting-is-applied/195945?noredirect=1#comment328626_195945

When I read it again, I realize that I didn't understand well how to weight paint with the mirror modifier (I got it now / the mirror modifier doesn't have to be applied)

Hope this can help a bit, but if even I cannot reproduce it I am not sure it is of any priority.

best regards,
Mathieu

Henrik Dick (weasel) closed this task as Invalid.Oct 6 2020, 10:54 PM
Henrik Dick (weasel) claimed this task.

Thanks for the report. Sadly it seems like the problem came from user error and is not a bug in blender.
Since nobody could reproduce this issue this report is considered invalid.

If there was a bug and you have a file which you can show it on, feel free to open a new bug.

Hello Henrik,
I am not sure how to contact you. I finally managed to redo the bug.
I made an explanation here:

https://1drv.ms/u/s!AuGa8VHo3JfFs3dAl1lEwl9BjUiJ?e=lIFsV8

let me know if you want to know more.

So, I solved the problem by deleting the point and recreating it. Otherwise, it was impossible to animate properly. I think that from the beginning my model had a lot of those weird symmetry things going on, but since I was redoing my topology a lot, they disappear little by little.