Page MenuHome

Blender 2.91 - UI Glitches
Closed, InvalidPublic

Description

System Information
Operating system: Linux Mint 20 with XFCE - 64 BIT
Graphics card: AMD ARUBA (DRM 2.50.0 / 5.4.0-48-generic, LLVM 10.0.0)

Blender Version
Broken: 2.91.0 Alpha, branch: master, commit date: 2020-09-28 19:10, hash: d5353eea5b28
Worked: Blender 2.90.1

Short description of error
UI glitches

Exact steps for others to reproduce the error
Based on the default startup. A graphic glitch appears in all boxes. It is as if the boxes were "triangulated", with the triangle at the bottom that is highlighted when the mouse is moved over.

Event Timeline

I don't know enough about the situation to triage this report, but this looks a lot like T78803, which is a known issue with graphics drivers.

I don't know enough about the situation to triage this report, but this looks a lot like T78803, which is a known issue with graphics drivers.

But to me the 2.90.1 works fine with the same drivers (see attachment)

According to this website the integrated GPU in the AMD A8-5600K processor is a AMD Radeon HD 7560D. This GPU has the TeraScale 3 micro-architecture, which is below the minimum requirement of GCN first generation or later for Blender 2.8x and 2.9x. Provided the information about the integrated GPU are correct, your hardware is not officially supported. You may still be able to run Blender, but graphics glitches or even crashes may occur due to issue with the graphics driver and/or hardware generation. Sometimes graphics driver updates, if available, may solve these issues. If that does not help, you will have to use an older version of Blender with lower minimum requirements.

Robert Guetzkow (rjg) closed this task as Invalid.Oct 1 2020, 5:28 PM
Robert Guetzkow (rjg) claimed this task.

According to this website the integrated GPU in the AMD A8-5600K processor is a AMD Radeon HD 7560D. This GPU has the TeraScale 3 micro-architecture, which is below the minimum requirement of GCN first generation or later for Blender 2.8x and 2.9x. Provided the information about the integrated GPU are correct, your hardware is not officially supported. You may still be able to run Blender, but graphics glitches or even crashes may occur due to issue with the graphics driver and/or hardware generation. Sometimes graphics driver updates, if available, may solve these issues. If that does not help, you will have to use an older version of Blender with lower minimum requirements.

Thanks for the reply. If you allow me, the only oddity is that both Blender 2.83.x and 2.90 work great with the same GPU + driver that creates the glitches in 2.91, so I assume something has changed in terms of openGL requests with the latest revision... or are the MESA drivers that do not agree 100% with 2.91, regardless of the GCN microarchitecture/instruction set

@Francesco Sorrentino (zeirus) I can't tell you what particular changes are causing the drawing issues on your system, just that you got lucky with the previous versions working without any problems.

@Francesco Sorrentino (zeirus) I can't tell you what particular changes are causing the drawing issues on your system, just that you got lucky with the previous versions working without any problems.

I don't want to insist but if you allow me it is not luck but something different between the code of 2.91 compared to 2.90. Furthermore, if we want to be precise, there is a fundamental error in the minimum requirements. My GPU not only implements OpenGL 3.3 as required, but even 4.5. And it is also under the age of ten (year of production 2012). So in my opinion the section on the minimum requirements should be corrected, at least for the 2.91 version of Blender, highlighting that AMD GPUs must necessarily be Radeon HD 8000 series to go up. This is to prevent other users like me from reporting bugs that are not bugs.

I don't want to insist but if you allow me it is not luck but something different between the code of 2.91 compared to 2.90.

Correct. What I meant was that there is no guarantee that Blender will work properly on systems below the minimum requirements. New commits aren't tested on this hardware and compatibility for these systems may break. Every new change makes it more likely that issues occur on this unsupported hardware. Since your GPU has already been below in the minimum requirements since 2.80, it is actually quite surprising that this is the first time you're experiencing such issues. That is what I meant with "you got lucky", since it already could've stopped working or had graphics glitches a few versions ago.

The minimum requirements are properly documented. Your GPU has to support OpenGL 3.3 or later, have at least 1 GB of memory and needs to match the requirements in the Supported Graphics Cards section. This section states for AMD GPUs "GCN 1st gen and newer" is required. In order to avoid any confusion what the GPU requirements are for, it explicitly states: "These requirements are for basic Blender operation, Cycles rendering using the GPU has higher requirements."

I don't want to insist but if you allow me it is not luck but something different between the code of 2.91 compared to 2.90.

Correct. What I meant was that there is no guarantee that Blender will work properly on systems below the minimum requirements. New commits aren't tested on this hardware and compatibility for these systems may break. Every new change makes it more likely that issues occur on this unsupported hardware. Since your GPU has already been below in the minimum requirements since 2.80, it is actually quite surprising that this is the first time you're experiencing such issues. That is what I meant with "you got lucky", since it already could've stopped working or had graphics glitches a few versions ago.

The minimum requirements are properly documented. Your GPU has to support OpenGL 3.3 or later, have at least 1 GB of memory and needs to match the requirements in the Supported Graphics Cards section. This section states for AMD GPUs "GCN 1st gen and newer" is required. In order to avoid any confusion what the GPU requirements are for, it explicitly states: "These requirements are for basic Blender operation, Cycles rendering using the GPU has higher requirements."

I fully agree with you but I wanted to highlight the Radeon HD 8000 series for a specific reason: not all users have advanced knowledge (nerd?) to be able to easily know if their GPU integrates the GCN, if not to do a targeted and precise search on Wikipedia. Usually the first reference that a user makes in the graphics field are the OpenGL versions. If they match the requirements it is "believed" to be okay, while they are not with regard to AMD GPUs. Adding a simple textual note that clarifies the minimum requirements costs nothing and would avoid unpleasant surprises, imho. And even the words "compatible with graphics cards less than 10 year old" should be corrected or eliminated completely, because it does not correspond to the truth.

I understand your idea and appreciate your input, but I disagree for multiple reasons:

  1. Radeon HD 8000 series is not the minimum requirement, there are models from the Radeon HD 7000 series that are GCN first generation or later, thus supported, and there are GPUs from the Radeon HD 8000 series that have the unsupported TeraScale 2 micro-architecture. Since there are GPUs within the same series that have different micro-architectures, it is necessary to list the required micro-architecture to provide accurate information to the user. Otherwise, they might be misled to buy new hardware although their GPU would've been supported or even worse they buy hardware that they believe is supported, but actually isn't.
  2. While it is true that people likely don't know what micro-architecture their GPU has, they can look it up on the linked Wikipedia page. The same problem would happen if we would just list a particular GPU series, like with Nvidia. If someone either does not read the requirements for the graphics cards or doesn't try to find out if their hardware fulfills the listed requirements, then no information we put on this page would make a difference. The only change that I would perhaps make is a note in bold that running Blender also requires a graphics card listed in the "Supported Graphics Card" section. Perhaps this helps users that only skim the minimum requirements.
  3. The minimum requirements do not state: "compatible with graphics cards less than 10 year old", it is "Less than 10 years old" for the entire system. Anything older than this is definitely not supported. A newer system doesn't automatically mean it will work / be supported, it also has to fulfill the other conditions listed on the page.

If you would like to continue the discussion about improvements to the minimum requirements page, I suggest you write a proposal and post it on DevTalk.

If you would like to continue the discussion about improvements to the minimum requirements page, I suggest you write a proposal and post it on DevTalk.

Yes, this is my intention. As you have pointed out there is a plethora of GPUs and although they may be part of the same family (like the Radeon HD 7000/8000, in my case) they are not all compatible with the latest Blender revisions because they have circuits "recycled" from previous GPUs . Same practice adopted by nVidia to dispose of the stocks of previous generations. From our speech we found that it is not easy to receive accurate information by mentioning only the GPUs or their publication date, if not knowing all the salient features by heart. I hope you have understood that if I insisted it is only to meet the needs of other users who are in the same situation as me and who find themselves having to buy an additional video card to overcome the glitches of the new version of Blender. Thank you for taking your time.