Page MenuHome

Blender 2.91 - Custom shortcut keys override the entire Set key interpolation
Confirmed, NormalPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX TITAN X/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 456.55

Blender Version
Broken: version: 2.91.0 Beta, branch: master, commit date: 2020-10-23 17:33, hash: rB70cc0d7121aa
Worked: -

Short description of error
When the user assigns a custom shortcut to the Set Key interpolation pop up menu, all interpolations
get the same shortcut menu assigned. The expected action is to get an independent shortcut keyboard targeting a specific interpolation method via shortcut key.

Since the bone constraints have different keyboard shortcuts individually assigned, I thought
that key interpolation in the fcurve could have the same individual assignments but it seems not possible
from the right-click->new shortcut->ctrl+shift+L on the "linear interpolation" option menu.

Exact steps for others to reproduce the error
Create a monkey
Open an Fcurve window. Set keyframe on frame #1. Move the monkey (rotate, move) to another place in 3d viewport.
Set another keyframe on frame #10
Select both keyframes, press "T" to get the interpolation pop up menu.
Right click over "LINEAR interpolation", select make new shortcut.
use CTRL+SHIFT+L
All the shortcuts in "Set Key interpolation" will now use CTRL+SHIFT+L

If the user opens Edit->user prefs->keymap->Graph editor->Graph editor (global)-> and creates a new shortcut using: graph.interpolation_type set to Linear, and set the keyboard shortcut, then it gets correctly created.

Event Timeline

Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

In fact, this operator's menu could work the same as other operators (eg Select Similar - Shif G), where you can sign a shortcut for each different property.
Having the same shortcut to each different property seems wrong.

So I'm confirming as a bug even though the UI API allows something like this.

yes there are several menus that have this issue and i think it's a bug too

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Oct 29 2020, 1:06 AM

I think this is a UI issue more than an animation issue.

Hey @Germano Cavalcante (mano-wii) I am not able to reproduce this bug. I think we can safely close it as resolved. Could you check once again?

Here is my system info for reference:
version: 2.92.0 Alpha, branch: master, commit date: 2020-12-04 19:00, hash: 3daf28388b73, type:
build date: 2020-12-04, 19:40:28
platform: Windows

@Himanshi Kalra (calra),
Strange that it was solved for you. Here I can still see the problem in the last master