Page MenuHome

Snapping doesn't work on non-square angles
Closed, ResolvedPublic

Description

System Information
Operating system: Win 10
Graphics card: 1060 3gb

Blender Version
Broken: version: 2.92

Short description of error
Snapping has different behaviour in 2.90 vs 2.91

It seems as if snapping is broken on anything that isn't a perfect 1:1 square
Steps to reproduce

Try to use the snapping feature in 2.91

https://www.youtube.com/watch?v=IBrot0WDQuw

Event Timeline

Hans Goudey (HooglyBoogly) changed the task status from Needs Triage to Needs Information from User.EditedJan 11 2021, 11:52 PM

Thanks for the report, but this doesn't contain enough information for us to fix any issue you're having. Please include the exact steps you took that lead up to the issue, and a description of how what happened is different than what you expected.

I tried using the snapping capabilities of this software, those are the exact steps I took + made a video showing the difference between the two versions. Is there some sort of new check box that likes to make this once working tool unusable?

I've updated my original post with an example blend file.
It's like non square objects don't snap correctly anymore. Try moving their verts to the other side and you should see what I mean.

Hans Goudey (HooglyBoogly) renamed this task from SNAPPING BROEKY to Snapping doesn't work on non-square angles.Jan 12 2021, 4:00 AM

Sorry, I can't reproduce the issue, and it seems like I've done every snapping combination of the vertices that I could test. Are you using the latest daily build? (One reason to report bugs directly from Blender is that it will automatically fill the report with that info)

I'm using the latest on steam.

I think the task description is inaccurate. Current 2.92 isn't broken, 2.91 is. There's been a fix (rBe4e7dfc1d8c0486530e5cabd2e448bf79b2fdb0b) that's slated as a candidate for a corrective release of 2.91. For now simply don't use mixed snapping (i.e. disable Incremental and only use Vertex).

Robert Guetzkow (rjg) closed this task as Resolved.EditedJan 12 2021, 10:22 AM
Robert Guetzkow (rjg) claimed this task.

I can confirm what @Stanislav Blinov (radcapricorn) said, this is already fixed in Blender 2.92. I'm closing the issue because the problem is solved in the upcoming 2.92 release and the commit has already been suggested to be included in a corrective release for 2.91.