Page MenuHome

Can't use this specific matcap
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 457.51

Blender Version
Broken: version: 2.91.0, branch: master, commit date: 2020-11-25 08:34, hash: rB0f45cab862b8
Worked: 2.83.9

Short description of error
Can't use this specific matcap

Exact steps for others to reproduce the error
Create a new scene, go to preferences/lights/matcap and import the attached file.
Now you should see the imported matcap in the list, but it won't show in viewport.

Thank you.

Event Timeline

For some reasons now the matcap is available and working correctly.

Thank you
Max

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.Jan 22 2021, 2:49 PM

I can't reproduce the issue in 2.91 or current master. It is listed in Viewport Shading > Matcap and is applied to the object just like the other matcaps. What exactly do you mean by "it won't show", is the object turning invisible or doesn't change appearance to before?

I was doing some experiments with custom matcaps, so I deleted/imported the same matcap a lot of time, maybe I broke something by doing that too much.
The matcap was in the list, but when I tried to select it, it didn't show up in the viewport, instead I got the first matcap (basic_1.exr).

After I while it worked again by it self.

Thank you

Robert Guetzkow (rjg) closed this task as Archived.Feb 7 2021, 12:16 AM

I've you are able to reproduce the error again, please try to note down the exact steps that led to it and create a new bug report with these information.