Page MenuHome

Fluid modifier affects particle hair (even when set to None)
Needs Developer to Reproduce, NormalPublic

Description

(blendfile attached : https://drive.google.com/file/d/1DwS8ZN3pF6nQY0i9CgwZgsIfeeG0TcSD/view?usp=sharing )
Used Blender 2.91.
Don't really know how to reproduce the because when I try reproducing the bug by adding a fluid modifier to a scalp before (in the modifier hierarchy his edited particle system, the hair edit changes in the edit particle, as well as it changes in object mode. However, with my original file, the hair edit don't change in edit particle mode, whether I hide the fluid modifier or not, it just changes in the other mode, e.g. object mode.

Hello,
My hair is very buggy and, I really, really need help on this.
I have a hairstyle composed of two layers, two particle system, one for the main hairs, and one for the frizzy hairs. The scalp where the hair is, has modifiers set up like this :

And here is a picture of the hair how I want em, and how I stylized em in the particle editor :

But this is how it looks when I disable the fluid modifier that the scalp has

And this is how it looks when I uncheck the “Dynamic Hair” box

I want to simulate my hair, but when I bake it, it comes out weird and deformed, plus, the main hair are static, there is only the frizz going crazy.
What am I doing wrong, please I really need help, at the end I want to be able to simulate my hair correctly, them looking exactly like the first picture, but without the fluid modifier, wich I think is causing problem in the sim.

If you can provide help, please do, It’s urgent, and I absolutely need this to get fixed, and If you can’t provide me help, like or upvote my post so that other users that can help, see my post.

(blendfile attached : https://drive.google.com/file/d/1DwS8ZN3pF6nQY0i9CgwZgsIfeeG0TcSD/view?usp=sharing )

Edit : If you wanna see the particles in edit particle mode, make sure this option is set to particles :

Event Timeline

Ankit Meel (ankitm) closed this task as Invalid.Fri, Jan 29, 9:53 AM

Bug tracker is not for user support, nor is there a concept of upvoting here. Please see Question/Answer sites among https://www.blender.org/community/

Bug tracker is not for user support, nor is there a concept of upvoting here. Please see Question/Answer sites among https://www.blender.org/community/

Yes but at this point I think it's a bug

Ankit Meel (ankitm) reopened this task as Needs Information from User.Fri, Jan 29, 11:07 AM

Please add blender version used, and steps to test the bug on other systems.

Please add blender version used, and steps to test the bug on other systems.

Thank you, I did

Ankit Meel (ankitm) changed the task status from Needs Information from User to Needs Triage.Fri, Jan 29, 3:12 PM

You have a lot of simulations going. It a matter of stack in my test but i am not certain what you want to achieve with the fluid sims and so.

The hair system is out of support and will hopefully replaced soon..

In my test and like i said its quite a complex file you can disable the force field on the other object and re-enable them after you disabled the hair sims. All your hair grooms dont have the use modifier stack enabled activated, in such a file as yours is pretty important so the groom takes the stack during backing. One of these is the mistake. The bad thing is that when you enable use modifier stack you need to regroom the hair.. Your forcefield might also be too strong

But why the groom changes when you disable the hair Dynamics is for some reason it gets affected by the forcefields. That can be checked with a fresh file and seeing if its really the case. Yep it is.. So might be a bug..

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

Simple steps to reproduce it

  1. New Fresh scene.
  2. Add particle system to default cube and change it to hair.
  3. Add a force field force and see that it changes the hair.
  4. enable hair dynamics and disable it to see the change.

here is the file with the steps above.

You have a lot of simulations going. It a matter of stack in my test but i am not certain what you want to achieve with the fluid sims and so.

The hair system is out of support and will hopefully replaced soon..

In my test and like i said its quite a complex file you can disable the force field on the other object and re-enable them after you disabled the hair sims. All your hair grooms dont have the use modifier stack enabled activated, in such a file as yours is pretty important so the groom takes the stack during backing. One of these is the mistake. The bad thing is that when you enable use modifier stack you need to regroom the hair.. Your forcefield might also be too strong

But why the groom changes when you disable the hair Dynamics is for some reason it gets affected by the forcefields. That can be checked with a fresh file and seeing if its really the case. Yep it is.. So might be a bug..

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

Simple steps to reproduce it

  1. New Fresh scene.
  2. Add particle system to default cube and change it to hair.
  3. Add a force field force and see that it changes the hair.
  4. enable hair dynamics and disable it to see the change.

here is the file with the steps above.

Thank you very much for your time, I'm gonna try what you adviced, also for the fluid, really it's a mistake, like it's not usefull I wanted to remove it but it was affecting the hair in a bad way If I was doing so. Do you think It'll be ok to simulate the hair with this fluid modifier on, or do you have a solution to remove it ?

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

This is the same as T71192: Forcefield impact on hair without hair dynamics checked and T55172: Hair is dynamic even it is disabled.
That is not considered a bug.

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

This is the same as T71192: Forcefield impact on hair without hair dynamics checked and T55172: Hair is dynamic even it is disabled.
That is not considered a bug.

Well and what about the fluid modifier that changes the hairstyle, only in edit mode while removed ?

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

This is the same as T71192: Forcefield impact on hair without hair dynamics checked and T55172: Hair is dynamic even it is disabled.
That is not considered a bug.

Well and what about the fluid modifier that changes the hairstyle, only in edit mode while removed ?

Well thats also not a bug. The modifier is before the particle hair and changes the geometry of the mesh (checking modifier stack in the hair particle setting should prevent that). When you remove it the hair has a different mesh and will change the groom depending on it. Its not as intuitive as it should like the force field changing the hair for no reason..

When its not a bug than this can be closed because thats the reason in this file why its changing and the modifier stack order but thats also not a bug. @Philipp Oeser (lichtwerk)

The force field is affecting the groom when hair dynamics are not enabled and when they are they are affected when the timeline plays. Is that by design?

This is the same as T71192: Forcefield impact on hair without hair dynamics checked and T55172: Hair is dynamic even it is disabled.
That is not considered a bug.

Well and what about the fluid modifier that changes the hairstyle, only in edit mode while removed ?

Well thats also not a bug. The modifier is before the particle hair and changes the geometry of the mesh (checking modifier stack in the hair particle setting should prevent that). When you remove it the hair has a different mesh and will change the groom depending on it. Its not as intuitive as it should like the force field changing the hair for no reason..

When its not a bug than this can be closed because thats the reason in this file why its changing and the modifier stack order but thats also not a bug. @Philipp Oeser (lichtwerk)

But the fluid modifier is just an effector ,how does it changes the mesh ? Do you mean I have to do all the hairstyle again If I remove the fluid modifier ?

No the type is set to none so it wont do anything to the hair. You can just let it on but like i said its because the hair is the last modifier and dont has the option enabled use modifier stack..

I would also advise when you have a question next time to post it on a different website for support and not here.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Developer to Reproduce.Fri, Jan 29, 5:46 PM
Philipp Oeser (lichtwerk) claimed this task.

Also a bit confused why the Fluid modifier (even when set to None) actually does something to the hair edit.
Will have another look with fresh eyes next week.

Philipp Oeser (lichtwerk) renamed this task from Hair Particle bug to Fluid modifier affects particle hair (even when set to None).Fri, Jan 29, 5:47 PM