Page MenuHome

Geometry Node cannot have two group output nodes at the same time
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: AMD Radeon(TM) R7 Graphics ATI Technologies Inc. 4.5.13539 Core Profile Context 24.20.13011.1009

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-01-29 16:35, hash: rBd0f59d38429d
Worked: (newest version of Blender that worked as expected)

Short description of error
Geometry Node cannot have two Group Output nodes at the same time, otherwise it will invalid.
The expected behavior in the Shader Editor:


Gometry Node Editor:

Exact steps for others to reproduce the error
Open the geometry Node Editor.
Duplicate the group output node, Subdivision Surface will invalid.

Event Timeline

Robert Guetzkow (rjg) renamed this task from Gometry Node cannot have two group output nodes at the same time to Geometry Node cannot have two group output nodes at the same time.Jan 30 2021, 9:47 AM
Robert Guetzkow (rjg) updated the task description. (Show Details)

This is a design question that would require a decision by the module team how this is intended to work.

Geometry nodes don't seem to follow the same concept as material nodes as there apparently should only ever be one group output. There also isn't an entry to add additional group outputs in the Add menu, but duplicating an existing node of that type works. Perhaps the copying & pasting and duplicating of the node should be prevented to be consistent in that only ever one is allowed or there needs to be a concept of an active output similar to the material nodes.

CC @Jacques Lucke (JacquesLucke)

Thank you for your reply.
One group output will be fine. In the shader editor, I like to use this method to check different parts of complex nodes. Emm... I have to say it is very useful :)

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Feb 1 2021, 4:43 PM

Will confirm for now, agree one of the two should be implemented:

copying & pasting and duplicating of the node should be prevented to be consistent in that only ever one is allowed or there needs to be a concept of an active output similar to the material nodes.

Dalai Felinto (dfelinto) closed this task as Archived.Feb 5 2021, 3:02 PM

Thanks for the report, but this is a not a bug. The system is working as it was designed to. It works the same way any other Node Group in Blender, including the ones used in material.