Page MenuHome

Turbulence field causing Blender to crash
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.40

Blender Version
Broken: version: 2.91.2, branch: master, commit date: 2021-01-19 16:15, hash: rB5be9ef417703

Short description of error
I have a rigid body and smoke system in my Scene. The rigid body system is already baked. I tried to add a turbulence field to affect the smoke. But it just crashes when I start playing. Then I tried out removing stuff but it did not fix it.

Exact steps for others to reproduce the error
Select the default cube. Object > Quick Smoke.
Add Cube add Rigid body active
Add turbulence field
Bake rigid body sim
When done --> Crash


Event Timeline

Benjamin (Phonix_64) updated the task description. (Show Details)
Benjamin (Phonix_64) added a project: Physics.
Falk David (filedescriptor) changed the task status from Needs Triage to Needs Information from User.Feb 4 2021, 10:52 AM

I cannot reproduce this on the latest alpha on Linux. Could you try the latest alpha or beta from https://builder.blender.org/download/ and see if the problem persists?

Benjamin (Phonix_64) added a comment.EditedFeb 4 2021, 11:33 AM

Oh, I am dum.... I Forgot to mention that bevor simulating you have to add a turbulence field.
But it still seems to work. Now I don£t understand anything anymore

Benjamin (Phonix_64) changed the task status from Needs Information from User to Needs Triage.Feb 4 2021, 11:58 AM
Benjamin (Phonix_64) updated the task description. (Show Details)

Okay, I am lost. Here is my .blend file when I play it it just crashes... With the newest 2.93 build

Still can't reproduce this. The file just simulates fine for me.

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Feb 5 2021, 10:28 PM

How to reproduce the problem from the attached file?
I opened it, and to bake the rigid body simulation I went to: Scene Properties -> Rigid Body World -> Cache -> Bake. But no crash.
Then I saw that I had to add a turbulence field.
So I opened the file again, added the turbulence field, went to Scene Properties -> Rigid Body World -> Cache -> Bake. But also no crash.
It is too time consuming to track down so I didn't open the other file to test.

Benjamin (Phonix_64) closed this task as Resolved.Feb 5 2021, 11:29 PM
Benjamin (Phonix_64) claimed this task.

Thanks for your Investigations. I found a method to avoid it by just baking the rgb sim to keyframes and then removing the rgb world.