Page MenuHome

Vertex painting not visible in object mode in vertex viewport shading
Closed, DuplicatePublic

Description

System Information
Operating system: Manjaro Linux Kernel 5.10.15-1, KDE Plasma 5.20.5
Graphics card: XFX AMD RX 570

Blender Version
Broken: 2.93.0 Alpha, dae445d94a7a, master, 2021-02-13 (I compile everyday and it looks like every version is broken)
Worked: 2.91.2

Bug: Vertex colors are not visible in object mode while viewport shading options are set to "vertex" and lightning to "flat".

Steps to reproduce: create cube mesh, move to vertex painting mode, "set vertex color"

, move to object mode, change lightning to "flat" and colors to "vertex".

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Mon, Feb 15, 11:58 AM

Do you have Sculpt Vertex Colors enabled in the User Preferences Experimental Features?

Yes, I do (I always turn everything on).

Then this is the same as T83891: Vertex Colors not displayed in object/edit/sculpt mode (if Sculpt Vertex Colors are enabled from Experimental).
This is not considered a bug:

When Sculpt Vertex Colors are enabled, they are used as the default data for rendering colors in the viewport, so regular vertex colors are ignored. The idea of that is to prepare vertex paint to handle any kind of data (not necessary colors), so it does not make sense to render the data that mode edits as color by default.

Afraid we have to close, feel free to comment again in T83891 if issues persist.