Page MenuHome

Issue with navigation in viewport display
Closed, ArchivedPublic

Description

System Information
Operating system: macOS Big Sur 11.2.3_
CPU: 2,8 GHz Intel Core i7 quad-core
Graphics card: Intel(R) Iris(TM) Plus Graphics 655 Intel Inc. 4.1 INTEL-16.1.12

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: (newest version of Blender that worked as expected)

Short description of error
Blender as I download the 2.92 version doesn't show the navigation gizmo and the way of navigating through the scene with the mouse is compromised: the rotation of the orbit while navigating through the scene is the opposite as usual.
Exact steps for others to reproduce the error
I just downloaded and opened it with this operating system

Event Timeline

Falk David (filedescriptor) changed the task status from Needs Triage to Needs Information from User.Mar 12 2021, 10:54 AM

Could you try the latest Alpha from https://builder.blender.org/download/ ? Thanks

Thank you for your quick response! with the latest Alpha version the gizmo appear but the viewport display rotation still act oppositely as it used to do with the 2.91 version: which is a little bit complicated to explain with words but I will try.

for instance with 2.91 if I rotated my mouse to the left (z axis) the viewport moved to the right, which in 2.92 and 2.93 was exactly the opposite, so it was difficult to navigate through the scene.
please tell me if you're getting what I am trying to say

Ok, then this is probably a duplicate of T86025. Can you check that this is the same issue?

Yes! apart from the navigation gizmo issue on 2.92 version, I have exactly the same problem, at least I just wanted to know if this changed was intentional, or if I can choose in the preferences with an option to put orbit exactly like in the 2.91 version.

Ok since the gizmo problem has been fixed in master, I will close this for now.

Note: The commit that fixes this should be bisected and added to T85958.

So I can use the blender 2.93 version or try to install again the 2.92? because I re downloaded the 2.92 and it stil doesn't show the gizmo

No, 2.92 has this issue, re-downloading won't fix it. There may be a corrective release (2.92.1) but that is unclear at the moment. You can either use 2.93 Alpha now or wait until a version with a fix is released.