Page MenuHome

UV Editor UDIM GRID disappear when add new image
Needs Information from Developers, NormalPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.40

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: (newest version of Blender that worked as expected)

Short description of error
When add image for UV editor, view > UDIM GRID options disappear.

Exact steps for others to reproduce the error
1 load default cube in new scene. Set UV editing as Active work space.
2 Right pane " View" tab. There is UDIM Grid option for background.


3 add new image. now UDIM Grid suddenly disappear. The Background UDIM grid only visible, when I remove Image from UV Editor.

The UDIM GRID can tell user, each UV Tiles when we manipulate UV. but it should not relate with image which check UV in UV editor.
If I set UDIM image, I can use image> UDIM tiles option. but when I just separate UV for each UV tile, with image, I do not need to set UDIM image.

Event Timeline

Thanks for the report, but this looks like a design discussion and not really a bug.

There is a list of tasks assigned to UDIM, you can see then in T72390: Improve UDIM functionality

As a feature request, I suggest you try other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests

I may have evaluated it wrong, so I'm leaving this report open (for a second opinion).


For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

OK I think it is a little annoying, but it work when I remove image from UV editor. so close please as you need.

The reason why I report it as bug, at current UV editor, often auto add image, when the mesh use image texture for material I feel.
Then when I need to edit UV to move along with UV grid, those grid option simply disappear. I did not notice I need to remove auto apply image for UV editor.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from Developers.Mar 29 2021, 1:59 PM
Philipp Oeser (lichtwerk) added projects: Restricted Project, Images & Movies, Render & Cycles.

@Lukas Stockner (lukasstockner97) : not sure about the check in the poll of IMAGE_PT_udim_grid.
Could you explain why we only want this shown if there is no image?

@Germano Cavalcante (mano-wii) i don`t feel it is feature request. It just works wrong way. And I don`t see any reason to keep such confusing behavior.
Also interested, what Lukas will answer.