Page MenuHome

Return hover shortcuts for mesh modifiers
Closed, ResolvedPublicTO DO

Description

At a UI meeting quite a while ago we decided to relax the idea that the shortcuts would only apply to the active item.
So this task just involves reverting some of the early changes to the modifier operators.

This is based on feedback (https://devtalk.blender.org/t/ctrl-a-for-applying-modifier-under-cursor-2-91-not-active-2-92-2-93/17490/14)
and the noticeably slower workflow for adding and duplicating modifiers.
Also, other modifier stacks (constraints, grease pencil, effects) still use the hover shortcuts as well.


Separately, I'd like to experiment with making the modifier icon blue instead of an outline around the box to indicate the active modifier.
We didn't really discuss this, but I think it would probably look better, and since the active modifier would be less important in this scenario (only controls context), it might make more sense too.


Initial feedback is that this isn't consistent with other areas in Blender (we don't use this blue icon for active idea)

Event Timeline

Hans Goudey (HooglyBoogly) changed the task status from Needs Triage to Confirmed.Mon, Mar 29, 2:15 PM
Hans Goudey (HooglyBoogly) created this task.

Having shortcuts affect not what seems to be selected is indeed confusing. This is not how the rest of Blender works : viewport, sequencer, ... every editor operates on selection. The problem here is that this is no selection, but looks like one. I'm not sure what being active entails for a modifier, but I think the indicator should be proportional to its importance. If we're going to have shortcuts affects the hovered modifier, then there needs to be a hover indicator that's more prominent than the active indicator.

Yes, totally agreed @Hadrien Brissaud (hadrien), I'd like to find a better way to indicate the active modifier.
Another reason it could be less prominent is that it only has an effect for nodes moidifiers, not any other types.
Unfortunately it doesn't seem like there's any very elegant way to do this, but maybe we'll just have to accept that.

Some more ideas I talked about with @William Reynish (billreynish):



There are other areas where shortcuts do not affect what is selected or active. For example in edit mesh mode "select linked" - Shortcut "L".
If you hover over a mesh island and press "L" the island is selected while the active or selected part of the mesh is not selected.
IMO having hover shortcuts like these is very useful and not inconsistent with the UI.

Having some sort of hover indicator seems useful, too but imo not necessary.

@Hans Goudey (HooglyBoogly) The radio button idea is consistent with other places in Blender (fcurve modifiers) and it serves that it's an explicit button instead of an "invisible-hitbox" activation like in 2.92. It's further less horizontal space in a place that's running out of it already though (unless the new datablock selector goes in as well?)

@Johannes Kollmer (Lumpengnom) sure what I mean is there's a visual sign -the outline- that suggests the operation is going to happen on it, because that's a code used Blender-wide. I'm not saying it's the only one, it's just a thing that users are most definitely expecting.

I'd like to propose the radio button idea to the team instead of the blue highlight, but that can be a separate task.

I'll commit the fix to the bug @Philipp Oeser (lichtwerk) mentioned in a few minutes.

Dalai Felinto (dfelinto) closed this task as Resolved.Mon, Apr 12, 4:38 PM