Page MenuHome

Bakeing Rigid Body too much slow
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 465.89

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: (newest version of Blender that worked as expected)

Short description of error
Hi,
last time (version 2.82) we solved together the Rigid Body scaling bug with a chain, setting in Rigid Body World:

  • Speed = 0.5
  • Substeps Per Frame: 600
  • Solver Iteration = 50

and Margin between rings to 0.0001.
Scaling the Rigid Bodies, the chain didn't explode more. Weel!
The process was very fast.
Now, I repeated the seme process with version 2.92 and the process is very very slow, so that I need to bake the simulation first.
At the end of simulation the chain explode...
It is normal?
See attachment.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Apr 9 2021, 4:11 PM

Can confirm, will check.

Philipp Oeser (lichtwerk) changed the task status from Confirmed to Needs Information from User.Apr 9 2021, 5:58 PM

Apparently caused by rBda95d1d851b4: Fix T75881: Animation, limitation of Bézier Handles, BUT:

  • your file is apparently written in (2, 92, 15)
  • that is why the versioning code does not do the following correction
/* The substep method changed from "per second" to "per frame".
 * To get the new value simply divide the old bullet sim fps with the scene fps.
 */

If this was an old file, this should have corrected the Substeps per Frame setting from 600 > 25
Then everything works correctly.

I am unsure how this got into this state (possibly by copy-pasting from an old file?)
What you can do:

  • correct Substeps per Frame setting from 600 > 25 "by hand" OR
  • save chain explode.blend again in 2.90 [where this was still working fine] and open in 2.92.0, versioning code then kicks in again and corrects this automatically.

I assume this is not a bug, is this working for you?

As Philipp said, they changed the "time resolution" setting for rigid bodies. When we set the time settings to the equivalent of pre 2.90 (600steps per second/24fps = 25 steps per frame) we get it to work in real time.

Philipp Oeser (lichtwerk) closed this task as Resolved.Mon, May 3, 6:12 PM
Philipp Oeser (lichtwerk) claimed this task.

Think it is safe to assume that this is resolved