Page MenuHome

Check if 3.0 is used correctly for buildbot, manual, Python API
Closed, ResolvedPublicTO DO

Description

With the change to 3.0 it is possible (likely even) that a few sites broke.

For instance:
https://docs.blender.org/manual/en/3.00/ -> https://docs.blender.org/manual/en/3.0/

List of services we need to check:

  • Python API page
  • Blender user manual
  • Package name (it is wrong: blender-3.00.0-09eb04c0a865-linux64.tar.xz)
  • Resources (data files, addons, ...) folder name (it is wrong: 3.00 -> 3.0)
  • Package name + folder for the make source_archive
  • Package name + folder for the make source_archive_complete
  • Redirect page: https://blender.org/download/releases/3-0/

Revisions and Commits

Event Timeline

Dalai Felinto (dfelinto) changed the task status from Needs Triage to Confirmed.Apr 15 2021, 5:45 PM
Dalai Felinto (dfelinto) created this task.

Splash screen "Release Notes" is currently requesting https://www.blender.org/download/releases/3-0/ and getting 404. I realize there is a redirection in place, but mentioning this because this format might be different from expected. And possible that 3.1 will request "3-10"

Sorry to spam this up. If by "Resources folder name" you mean folder in the output folder that contains datafiles, scripts, python.

Before last week this change to version 300 was resulting in an output folder name of "3.0" but then python would not be found and blender would die while starting. That is why Campbell added a correction that appends zero to a make var so that the folder is "3.00" and everything works. We could certainly fix it the other way, leave the folder at "3.0" and fix how things are found. That would just mean undoing e9c548c3c319. In doing so we'd then have to deal with (easy problem) of setting minor version for Windows resource compiler. And also note that next version 3100 would, without further changes, create a "3100" folder. So mostly just saying that there is some complexity here.

Right, that means indeed we should revert this and have Python looking at the correct folder (3.0).

Dalai Felinto (dfelinto) triaged this task as Unbreak Now! priority.Apr 15 2021, 7:03 PM
Dalai Felinto (dfelinto) updated the task description. (Show Details)

Even though this task is "unbreak now", i'm gonna go through review with D10986, given my time zone feel free to commit on your own while i sleep :)

Dalai Felinto (dfelinto) closed this task as Resolved.Apr 16 2021, 11:31 AM
Dalai Felinto (dfelinto) claimed this task.

From what I could test here, Python API page is working as well. Building 3.0 as release leads to the correct page for the API and the manual. I will close this now. Thanks everyone for the help.