Page MenuHome

Black Squares appearing with transparent glass shader in cycles render
Closed, ArchivedPublic

Description

I have a glass material applied to an object I am rendering in Cycles, but whenever I render it the material generates these black squares around it. the Object is light by an HDRI, however even without the HDRI it still has this issue. I changed the values in the "max bounces" section of the Render Properties tab, but to no effect.

See Stack exchange post for visual representation:
https://blender.stackexchange.com/questions/219732/black-patches-appearing-on-glass-materal-in-cycles-in-viewport-preview

SYSTEM INFO :

OS Name Microsoft Windows 10 Home
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-0IFCI2P
System Manufacturer Alienware
System Model Alienware Aurora R9
System Type x64-based PC
System SKU 0961
Processor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 Mhz, 8 Core(s), 8 Logical Processor(s)
BIOS Version/Date Alienware 1.0.8, 2/20/2020
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Alienware
BaseBoard Product 0T76PD
BaseBoard Version A02
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.19041.844"
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.8 GB
Available Physical Memory 6.67 GB
Total Virtual Memory 21.8 GB
Available Virtual Memory 5.80 GB
Page File Space 6.00 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Event Timeline

Robert Guetzkow (rjg) closed this task as Archived.Apr 16 2021, 9:41 AM

Thank you for your report. Unfortunately, it does not contain the requested information that we need to investigate the issue. Please read this guide, it may help you write a bug report that allows us to identify the cause of the problem.

In case you believe that you've found a bug, please create a new bug report through Help > Report a Bug in Blender. We expect all bug reports to follow the submission template. Please provide system information (operating system, GPU, graphics driver version), affected Blender version, previous Blender version that worked properly, a short and precise description of the issue, step by step instructions to reproduce it and, if relevant, a minimal .blend file that showcases the problem.