Page MenuHome

Poselibrary 'flip pose' function is causing lattice controls to rotate unexpectedly
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.8.0-7630-generic-x86_64-with-glibc2.32 64 Bits
Graphics card: AMD Radeon RX 5700 XT (NAVI10, DRM 3.38.0, 5.8.0-7630-generic, LLVM 11.0.0) AMD 4.6 (Core Profile) Mesa 20.3.2

Blender Version
Broken: version: 3.0.0 Alpha, branch: asset-browser-poselib, commit date: 2021-05-11 09:39, hash: rB745505278d3c
Worked: (newest version of Blender that worked as expected)

Short description of error
When applying a pose including (lattice controls) with 'Flip Pose' enabled, the lattices behave unexpectedly, rotating in 180 degrees. even though their rotation value stored on the poselibrary is 0,0,0.

Exact steps for others to reproduce the error
Append/link a character with lattice controls in a file
after hitting 'n' in the viewport, Open the 'animation tab'
Create a pose with the lattices included and save it to the poselibrary. The pose will be stored in the 'current file'.
Then enable 'Flip Pose'.
Click and drag on the just created poselibrary pose and the lattice will rotate 180 degrees.

File has been included with a pose saved and applied to the file.

The action 'ANI-Ellie_test_FlipPose' shows the keyed pose 'regular' on frame 10 and 'flipped' on frame 20

Event Timeline

Ankit Meel (ankitm) changed the task status from Needs Triage to Needs Information from User.Jun 16 2021, 4:25 PM

changing status for the blend file

This is caused by the X-axis of the bone pointing upwards:

The pose flipping code assumes that the X-axis of the bone is oriented left-right, and that thus flipping the X-axis will flip the pose correctly.

A potential fix is available in the temp-pose-flipping-fix-attempt branch, should be downloadable at https://builder.blender.org/download/experimental/ soon.

Sybren A. Stüvel (sybren) changed the task status from Needs Information from User to Confirmed.Jul 13 2021, 3:57 PM
Sybren A. Stüvel (sybren) closed this task as Resolved.
Sybren A. Stüvel (sybren) claimed this task.

A fix has been committed in rBac441249b4c0: Fix T88281: Pose Library 'flip pose' sometimes flips wrong to the asset-browser-poselib branch used by the Blender Studio animators. It'll be committed to master when the pose library itself gets committed.