Page MenuHome

EEVEE AO Shader ignores scene AO settings
Closed, ArchivedPublic

Description

System Information
Operating system: macOS-11.4-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 5500M OpenGL Engine ATI Technologies Inc. 4.1 ATI-4.5.14

Blender Version
Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: rB1b8d33b18c2f
Worked: 2.92

Short description of error
AO Shader ignores scene AO settings

Exact steps for others to reproduce the error
open the attached blend file. use a higher factor (i.e. 3.0) for AO in main settings. The shader will ignore the factor.
making the same steps in 2.92 will produce a multiplied AO in the shader

Event Timeline

Ivan Cappiello (icappiello) renamed this task from AO Shader ignores scene AO settings to EEVEE AO Shader ignores scene AO settings.Tue, Jul 6, 4:55 PM
Ivan Cappiello (icappiello) created this task.

Can't confirm on Linux

Can't confirm on Linux

@user1 (user1)
please add some specific detail about OS, Machine, and blender version.
Just tested on Linux UBUNTU 18.04.4 LTS + GEForce GTX570 + Blender 2.93.1, and the issue is present.
Also, don't play with distance setting in the AO shader. Just open the same file in both 2.92 and 2.93 and compare results.

user1 (user1) added a comment.EditedWed, Jul 7, 11:27 AM

Operating system: Linux-5.4.0-77-generic-x86_64-with-glibc2.27 64 Bits
Graphics card: GeForce GT 630/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.143
3.0.0 Alpha, branch: master, commit date: 2021-07-05 22:24, hash: rB4eeec6e9b540

Operating system: Linux-5.4.0-77-generic-x86_64-with-glibc2.27 64 Bits
Graphics card: GeForce GT 630/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.143
3.0.0 Alpha, branch: master, commit date: 2021-07-05 22:24, hash: rB4eeec6e9b540

@user1 (user1) Then you are not testing correct blender version. Should be 2.93.1 you are instead testing on Blender 3.0 Alpha.

edit:
i also double checked using 3.0alpha and the issue is present there too.

Adriano D'Elia (aDElia) changed the task status from Needs Triage to Confirmed.Wed, Jul 7, 11:32 AM

confirm on linux too.

Operating system: Linux-5.4.0-74-generic-x86_64-with-glibc2.27 64 Bits
Graphics card: GeForce GTX 570/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.143
Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: rB1b8d33b18c2f

Can't confirm with 2.93.1 (on same system as above):

unfortunately can confirm the issue on 3.0alpha too

Operating system: macOS-11.4-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 5500M OpenGL Engine ATI Technologies Inc. 4.1 ATI-4.5.14
Broken: version: 3.0.0 Alpha, branch: master, commit date: 2021-07-06 23:09, hash: rB6ac3a106190c

Can't confirm with 2.93.1 (on same system as above):

@user1 (user1)
Please follow instructions. Download the blend file and use it. Seems quite clear to me you are not testing the same blend file moreover the plane has a different material (and so obviously reacting to the general AO instead of using the shader). If you look at the monkeys they have a completely different AO ignoring the settings you cranked up in the main settings, and respecting what you manually set in the shader (which you should not touch btw).

If you want to help please follow the attached instruction to reproduce:

Exact steps for others to reproduce the error
open the attached blend file. use a higher factor (i.e. 3.0) for AO in main settings. The shader will ignore the factor.
making the same steps in 2.92 will produce a multiplied AO in the shader

Sorry for the unconvenience. You're right - with the given file i can reproduce the issue.

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Jul 7, 4:01 PM

I think the 2.93 behavior is correct, and consistent with Cycles as well. The AO node is mainly intended for texturing, not lighting. For example to add wear on corners. For such cases the texture should not be affected by the scene lighting settings.

@Brecht Van Lommel (brecht) thanks for the clarification.
Unfortunately this affect badly toon shaders created in 2.92 and ported to 2.93. But as long as this is not going to change again, i am ok with fixing the toon shaders AO inside the node.