Page MenuHome

Rigify UI throws an error ('thigh_fk' cannot be found)
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 471.11

Blender Version
Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: rB1b8d33b18c2f
Worked: 2.92

Behavior changed in rBafa5da9ce02b: Cleanup: remove check for non-annotation properties in classes

Short description of error
Rigify UI throws an error ('thigh_fk' cannot be found)

Exact steps for others to reproduce the error

  • Open above .blend (allow rigify UI script execution)
  • select all bones
  • open the sidebar N panel
  • notice a lot of controls missing (use 2.92 to see the difference)
  • notice an error in the console:

"Python: Traceback (most recent call last):

File "C:\Users\rolan\Dropbox\Blender\Pixelodeon\Modulo 2\07 Cuepro completo\Personaje.blend\rig_ui.py", line 793, in draw

AttributeError: 'POSE_OT_rigify_leg_fk2ik_zdqgjyjd0c7e85b5' object has no attribute 'thigh_fk'

location: <unknown location>:-1

Event Timeline

Can please add a simple test file with steps to reproduce ? Issue is possibly related to rigify addon so changing the tag

Pratik Borhade (PratikPB2123) changed the task status from Needs Triage to Needs Information from User.Sat, Jul 17, 5:41 PM

Hi there, this is the same file that I've using when the problems appears.

Thanks and sorry my english, I'm from Chile... but I try hard to make me understand!

  • RAS
rolando aguilera (rolando.aguilera) renamed this task from Insert keyframe for all bones selected doesn't work with the "n" panel shown... I hace to close it to go on. to Insert keyframe for all bones selected doesn't work with the "n" panel shown... I have to close it to go on..Sun, Jul 18, 8:19 PM

Think the keyframes are actually inserted correctly.

Rigify has a problem though [which was still possible in 2.92, only 2.93 onwards has this problem]:

Info: Successfully added 750 keyframes for keying set 'BBone Shape'

Python: Traceback (most recent call last):
  File "/T89910/fm 001.blend/rig_ui.py", line 793, in draw
AttributeError: 'POSE_OT_rigify_leg_fk2ik_zdqgjyjd0c7e85b5' object has no attribute 'thigh_fk'
Philipp Oeser (lichtwerk) renamed this task from Insert keyframe for all bones selected doesn't work with the "n" panel shown... I have to close it to go on. to Rigify UI throws an error ('thigh_fk' cannot be found).Mon, Jul 19, 1:57 PM
Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Needs Information from Developers.
Philipp Oeser (lichtwerk) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) updated the task description. (Show Details)
Demeter Dzadik (Mets) closed this task as Archived.EditedTue, Jul 20, 4:38 PM

In the attached file, the properties in rig_ui.py are defined using the old = assignment, but looking at the git blame of the code that generates that code, it has been kept up to date immediately with Blender 2.8, and changed to the new : annotation syntax.

So this means your rig was generated with a version of Rigify and Blender that are more than 3 years old, and that's why it's no longer compatible with current Blender.

The ideal solution here is to find the metarig that generated this rig, and re-generate it with the current Rigify. If that's not available because the rig's author has made the huge mistake of discarding the metarig (which should never ever be done) then your best bet is to simply go into rig_ui.py and replace the = signs in the operator class definitions with : signs, as per Blender 2.80 Python API requirements.

Thanks for the report, but there's no bug here, so closing. Hope the above info will help with the problem though.

Thanks a lots, and sorry for reporting a non bug issue!

Cheers... and also thanks for all your work!!

  • RAS