Page MenuHome

Cycles-X: OpenVDBs render differently between CUDA and OptiX
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.10.0-8-amd64-x86_64-with-glibc2.31 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 470.63.01

Blender Version
Broken: version: 3.0.0 Alpha, branch: cycles-x, commit date: 2021-09-14 15:01, hash: rB58ab616d4c6e
Worked: Pre-Cycles-X

Short description of error
The rendering of clouds, specifically tested with OpenVDB files, I'm not sure if it can be replicated via other means, are quite different between CUDA and OptiX with OptiX looking the most "correct". Here are some images:

Rendered with OptiX (Seems more correct)Rendered with CUDA

Exact steps for others to reproduce the error:

  1. Import a OpenVDB into Blender. I used the WDAS cloud file. The higher the resolution OpenVDB you use the more noticeable it seems to be. https://www.disneyanimation.com/data-sets/?drawer=/resources/clouds/
  2. Add a light to the scene, make sure the cloud OpenVDB file has a principled volume shader with the density adjusted to make it rather opaque, then render the scene and compare it between CUDA, OptiX, and CPU.

Here's a file I created. It makes use of a lower resolution OpenVDB (to decrease file size) but the issue is still there:

Related Objects

Event Timeline

Alaska (Alaska) closed this task as Archived.Sep 15 2021, 9:12 AM
Alaska (Alaska) created this task.

Bug report for Cycles-X. Reported here for ease of access but archived because we do not accept bug reports for Cycles-X yet.