Page MenuHome

Adaptive sampling down-samples volume scattered shaded objects
Closed, ArchivedPublic

Description

Blender Version
Broken: 2.934
Worked: none

Short description of error
When using Adaptive sampling render option (Cycles+Branched path tracing) down sampling happen on volume scattered shaded objects.

If one applies volume scatter shader for an object, like for generating cloud,
and this cloud is in front of an environment texture where adaptive sampling is applying less samples,
lesser sampling is applied to the cloud itself.

This is always happening to volume scatter shaded objects. Then, sample rate applied is same as for background object, but, correctly, it should be max samples.

Adaptive ON has more artifacts. Best to see difference is to compare cloud edges.

Exact steps for others to reproduce the error

Blend example... (Render frame using Adaptive ON and OFF.)

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Sep 27 2021, 9:06 AM

Can you check if you can reproduce issue like this in latest alpha from https://builder.blender.org/download/daily/? Branched path tracing has been removed, but perhaps it is still possible to trigger the issue.

It is hard to compare v3.0 vs 2.934 LTS. I specifically use Branched PT because scene is 360deg light source and BPT gives me better performance, faster convergence. But, I will try to repo on v3.0.

Vladimir (vbSigma) added a comment.EditedSep 27 2021, 9:08 PM

@Richard Antalik (ISS) ... I have tried at v3 alpha. It is very new to me and it is hard for me to put new render engine in equivalent situation like when rendering by v2.934. But, for v3.0 case, it seems there is no problem. Again, I'm not sure how to tune it at v3 alpha.

Also, I have corrected & uploaded example blend to use less memory.

@Richard Antalik (ISS) ... I have tried at v3 alpha. It is very new to me and it is hard for me to put new render engine in equivalent situation like when rendering by v2.934. But, for v3.0 case, it seems there is no problem. Again, I'm not sure how to tune it at v3 alpha.

I understand, but 2.93 does receive only critical fixes - that is usually limited to crashes and bugs that make program unusable. Personally I don't think this issue can be fixed in 2.93.
So then question is if this is valid bug for 3.0.

OK, that's fine for me...sorry for disturbance, didn't understand LTS policy.

@Vladimir (vbSigma) did you manage to reproduce this issue in 3.0 verson? just checking if this needs to be investigated still.

@Richard Antalik (ISS)

I tried, but V3 is totally different ... tried equivalent and it seems V3 does not have issue.
I recommend further study by a person familiar with V3.

Richard Antalik (ISS) closed this task as Archived.Oct 15 2021, 1:48 AM

Thanks, so I will close this report for now. Thanks for reporting though.