Page MenuHome

Cycles HIP graphics interop issue on AMD 5500 XT and Windows
Closed, ResolvedPublicBUG

Description

Found by @Thomas Dinges (dingto) testing the latest build and beta drivers.

It appears there is an issue in graphics interop with OpenGL, both in viewport render and F12 render:

I1109 20:10:49.577401 1880 path_trace_work_gpu.cpp:810] Using graphics interop GPU display update.
E1109 20:10:49.577401 1880 graphics_interop.cpp:61] Error registering OpenGL buffer: Invalid handle

Full log: P2585

The quick solution may be to disable graphics interop. It's unclear if this happens on specific GPU generations, or if it's a bug in Blender or the AMD driver.

Event Timeline

Brecht Van Lommel (brecht) changed the task status from Needs Triage to Confirmed.Nov 9 2021, 8:24 PM
Brecht Van Lommel (brecht) created this task.

@Brecht Van Lommel (brecht) Tested with the new build with D13167 in it, unfortunately same result.

It's not using interop though, so there must be another issue.

I1110 08:59:55.989177 14144 path_trace_work_gpu.cpp:813] Using naive GPU display update.
Brecht Van Lommel (brecht) changed the subtype of this task from "To Do" to "Bug".Nov 10 2021, 12:17 PM

@Thomas Dinges (dingto) does the log without graphics interop contain any other error messages?

@Brecht Van Lommel (brecht) Log with default cube again, but no errors.

Hi team I have this Issue but as I saw it's fixed how I can fix it in the version that I use ?

Make sure you use the latest Blender 3.0 or 3.1 build from https://builder.blender.org/download/daily/