Page MenuHome

Animated curves flickers when Motion Blur and Persistent Data are enabled
Confirmed, NormalPublicBUG

Description

If there is an animated curve and Motion Blur + Persistent Data are enabled, the curves will randomly appear and disappear. Here is a simplified file that reproduces the issue on master. Render the animation an notice how the curves flicker.

Original Report

System Information
Operating system: Windows-10-10.0.19043-SP0 64 Bits
Display Graphics card: Radeon RX 580 Series 4.5.14800 Core Profile Context 22.3.1 30.0.15002.1004
CUDA enabled Graphics card: NVIDIA GeForce GTX 1650 Driver version. DCH 472.12
CPU: Ryzen 7 2700 (16 threads, 8 cores)

Blender Version
Broken: version: 3.2.0, branch: master, commit date: 2022-06-08 10:22, hash: rBe05e1e369187
Worked: (newest version of Blender that worked as expected)

Description of error
Objects disappear from what seems to be random frames close to the beginning of keyframed object transformations in renders produced with Cycles (only).
This appears to be the same bug as archived T40313.

Bug is more prevalent in blender version: 3.1.2 however is still present.
Render Examples:
3.1:


3.2:

This Project was using AnimAll addon to animate some of the objects featuring the glitch, these appare to be the only ones still glitching in 3.2. However testing this Addon in a controlled environment does not feature this behaviour, which might suggest its cause is elsewhere, but might be aggravated by animating individual vertices.

Exact steps for others to reproduce the error

  • Open Attached Blend file
  • Render Animation in Cycles using files settings.

This render was made using GPU Compute with CUDA and CPU enabled in system preferences.
Edit: works on CPU only also. Updated .Blend file with packed textures.

File removed now simplified is available

Event Timeline

Thomas (Geo0rbit) updated the task description. (Show Details)
Omar Emara (OmarSquircleArt) changed the task status from Needs Triage to Needs Information from User.Jul 4 2022, 2:27 PM

It is not clear which objects are disappearing in the attached video, can you clarify that?
Also, the attached file does not include the textures, are they necessary for reproduction?
Is this specific GPU+CPU rendering or can it be replicated using CPU only?

I can confirm running on CPU only also produces this error.

I am unfamiliar with including textures in portable .blend files, the project relies heavily on Alpha channels, so it would ceritnaly help readability when debugging.

Objects will dissapear for a frame then re-appear, this happens continuously with the cables on the right side of the background (3.1 and 3.2), which are on a cyclic loop animation curve modifier, I believe they dissapear just before there next cycle.
Attached bellow is an example of a non cyclic element disappearing for a frame (only on 3.1).

On frame 93 and 95 of the exported file the foreground element highlighted in blue is rendered but at 94 it disappears (frame 3000 from the file).

f 93
f 94

Hide from render keyframes are in use but not at this point in the timeline and not on this object.

I can't replicate the disappearance from frames 2999 to 3001, but that was without the FX layer, which I guess you disabled it in the file, so it is not important for replication?
Can you try rendering using factory settings to rule out any interference with add-ons? File > Defaults > Load Factory Settings.

The FX layer should be disabled from viewport but not from render due to performance when previewing in evee, therefore should not effect the result eitherway, as its being rendered in cycles as described in the steps.

To replicte it is vital to render an animation to ffmpeg NOT indervidual frames to image, the example for frames 2999 - 3001 will only appear in renders done with blender 3.1.2.
To view this artifact in 3.2.0 you need to look at the cables in the background.
This 'artifact' does not appare to be resolution dependent.


this version captures both the cables and the foreground element dissapareing (3.1) -ive burnt the frame numbers into the file. performing the render twice seems to yeald consistant results rather than random. I cant confirm if thats identical to longer renders though, it seems like the timing is different to me on when these objects disappear.

In 3.2.0 this artifact is much less relibibly re-produced, I connot replicate this with a slice of frames, instead, the cables only disappear on a longer render.

At frame 2958 the 3rd cable will disappear.

In this slice though it does not show up.

Perhas a memory issue? I did these renders at approximately 64% ram usage @ 16gb.

after re-rendering the animation from 2938-2965 (3.2) it did not disappear at the same point, so I suppose it might be more random than I thought.

Much to my surprise when rendering with factory settings + CUDA the artifact still occures.

I dont want to render this just on cpu unless i really have to, especially considering ive already identified the glitch can occur with those settings.

Its probably worth noteing without having tested shape keys, to my knowledge I wouldn't have been able to animate these background elements without AnimAll. Im more concerned that elements not being effected by AnimAll might not be safe from this artifact either, and its just much less likely to occur on 3.2. i.e something has accidentally partially fixed it in the codebase.

I could replicate the 3.1 (2999-3001) issue reliably, and I suspect it is due to Persistent Data, can you confirm that disabling Render > Performance > Persistent Data resolves the issue?

spam (meghanewgirl1) closed this task as Archived.Jul 6 2022, 9:07 AM
This comment was removed by Thomas Dinges (dingto).
Omar Emara (OmarSquircleArt) reopened this task as Needs Information from User.Jul 6 2022, 9:11 AM

Can also reproduce on master on the range 2938-2965 as you demonstrated. The issue also seems to be persistent data. Trying to see if the file can be simplified.

Omar Emara (OmarSquircleArt) changed the task status from Needs Information from User to Confirmed.Jul 6 2022, 11:10 AM

It seems Motion Blur + Persistent Data is the cause, might be similar to T96822. Here is a simplified file that reproduces the issue on master.

Omar Emara (OmarSquircleArt) renamed this task from Objects Disappear from Frames During Object Transformation in Cycles Render to Animated curves flickers when Motion Blur and Persistent Data are enabled.Jul 6 2022, 11:11 AM
Omar Emara (OmarSquircleArt) updated the task description. (Show Details)

This does seem to be the same Artifact.
Thanks for simplfying the file I wasnt sure if that would make the bug go away considering it seems to be coming from multiple objects.
So basically 94205e1d0295 fixed this issue in 3.2 but it doesnt fix it for animated curves?

Interestingly the bug disappears for me on the simplified file when you do the following with persistent data and motion blur on:
-slide the keyframes of the curves into the rendered frame zone (between start and end frame).
-Scale animation curve in until the majority of the animation is within the start and end frame zone.
-select all objects in viewport.
-render animation.

If thats interesting to you heres the file:

So far I am unable to reproduce the bug from scratch nativly in 3.2, is it possible its bad data from the file made in 3.1?

For the time being then if the bug shows up, a valid work around is to disable motion blur, unless its vital to the project in which case you can disable persistent data at a significant loss to cycles render times.

Brecht Van Lommel (brecht) changed the subtype of this task from "Report" to "Bug".Fri, Aug 5, 6:04 PM