Page MenuHome

Lissanro Rayen (Dragon.Studio)
User

Projects

User does not belong to any projects.

User Details

User Since
Dec 5 2018, 3:19 PM (63 w, 12 h)

Recent Activity

Tue, Feb 11

Lissanro Rayen (Dragon.Studio) added a comment to D6554: Cycles: Add support for denoising in the viewport.

I have tested new version of the patch and everything works great. I found no issues.

Tue, Feb 11, 6:26 AM

Sat, Feb 8

Lissanro Rayen (Dragon.Studio) added a comment to D6554: Cycles: Add support for denoising in the viewport.

@Wadii Bellamine (Liquidwad)
Alternative to get better interactive performance is to decrease Start Pixels a bit, making it smaller by 5% or 10% is much less noticeable than turning off denoising but improves speed by about 10% or 20% respectively, probably enough to compensate for lag introduced by interactive denoising on lower-end cards. I have RTX 2060 SUPER, performance-wise it is something in between RTX 2060 and RTX 2070. So it can be considered one of the lower-end RTX cards but I did not notice any effect on interactivity when testing interactive denoising. I did not measure OptiX denoiser speed in Blender exactly but I remember reading somewhere that even on some old non-RTX card (GTX 1080 if I remember correctly) denoising with OptiX 700x700 image takes about 18-19ms. My guess people with lower-end cards most likely will be limited to lower Start Pixels resolution if they care about interactivity, such as 256px or 384px (few times less pixels than in 700x700), so lag because of interactive denoising will be hardly noticeable.

Sat, Feb 8, 7:31 AM

Fri, Feb 7

Lissanro Rayen (Dragon.Studio) added a comment to D6554: Cycles: Add support for denoising in the viewport.

Latest patch works well, I confirm that issue with interactivity is solved.

Fri, Feb 7, 6:24 PM

Wed, Feb 5

Lissanro Rayen (Dragon.Studio) added a comment to D6554: Cycles: Add support for denoising in the viewport.

I think interactivity is lost because enabling denoising for some reason significantly reduces FPS in large viewport, especially for Cycles (even though denoising is not applied while Cycles rendering at Start Pixels resolution). In nvidia-settings I set "X Screen 0" > "OpenGL Settings" > "Enable Graphics API Visual Indicator" and in large viewport with Cycles rendering if I enable denoising OpenGL FPS becomes 10-13 FPS with default cube scene (approximately 2100x1200 viewport) and worst of all, Cycles preview is not interactive anymore (Cycles FPS drops to zero in large viewport), only overlays are moving when I'm rotating view with middle mouse button.

Wed, Feb 5, 8:53 AM

Tue, Feb 4

Lissanro Rayen (Dragon.Studio) awarded D4960: New Remeshing Modes for Remesh Modifier a Love token.
Tue, Feb 4, 7:52 PM · Modifiers, BF Blender
Lissanro Rayen (Dragon.Studio) added a comment to D6554: Cycles: Add support for denoising in the viewport.

The latest version of the patch works for me, huge improvement since it allows me quickly see what a scene looks like almost without noise. But I noticed two issues (I have 8GB RTX card, and I use GPU with OptiX for rendering):

Tue, Feb 4, 5:56 AM

Wed, Jan 29

Lissanro Rayen (Dragon.Studio) awarded D6554: Cycles: Add support for denoising in the viewport a Love token.
Wed, Jan 29, 10:35 PM

Mon, Jan 27

Lissanro Rayen (Dragon.Studio) awarded D4686: Adaptive Sampling for Cycles. a Love token.
Mon, Jan 27, 8:47 PM · Cycles, BF Blender (2.83)

Jan 16 2019

Lissanro Rayen (Dragon.Studio) added a comment to D4212: Physically based defaults for Eevee Bloom and Shutter.

Why not scale accordingly and map ui 1.0 == 0.1 behind the scenes etc?

Jan 16 2019, 2:23 PM · Eevee
Lissanro Rayen (Dragon.Studio) updated the diff for D4212: Physically based defaults for Eevee Bloom and Shutter.

Thank you for reviewing the patch. I have fixed style issue and updated default bloom_clamp value to 0.0f.

Jan 16 2019, 1:21 AM · Eevee

Jan 15 2019

Lissanro Rayen (Dragon.Studio) created D4212: Physically based defaults for Eevee Bloom and Shutter.
Jan 15 2019, 10:47 AM · Eevee

Jan 12 2019

Lissanro Rayen (Dragon.Studio) created T60450: After denoising tiles rendered by GPU turn black (regression).
Jan 12 2019, 9:23 PM · BF Blender

Dec 14 2018

Lissanro Rayen (Dragon.Studio) added a comment to T59359: In 2.80 some objects with multires modifier (originally created in 2.79b) are with broken geometry.

It seems I have uploaded corrupted .blend, I cannot open it either. Sorry about that, not sure how this happened. I have attached new .blend file. To make sure everything is OK, I downloaded it and I can open it in both 2.79 and 2.80.

Dec 14 2018, 3:03 PM · Tracker Curfew, BF Blender
Lissanro Rayen (Dragon.Studio) raised the priority of T59359: In 2.80 some objects with multires modifier (originally created in 2.79b) are with broken geometry from 30 to 90.
Dec 14 2018, 2:56 PM · Tracker Curfew, BF Blender
Lissanro Rayen (Dragon.Studio) updated the task description for T59359: In 2.80 some objects with multires modifier (originally created in 2.79b) are with broken geometry.
Dec 14 2018, 11:15 AM · Tracker Curfew, BF Blender
Lissanro Rayen (Dragon.Studio) created T59359: In 2.80 some objects with multires modifier (originally created in 2.79b) are with broken geometry.
Dec 14 2018, 10:34 AM · Tracker Curfew, BF Blender

Dec 5 2018

Lissanro Rayen (Dragon.Studio) added a comment to T58317: Print3D addon failed.

I have encountered this issue when I try to check Thickness, all other checks seems to work fine with default cube.

Dec 5 2018, 6:36 PM · Add-ons
Lissanro Rayen (Dragon.Studio) updated the task description for T58798: 3D Print Toolbox fails to calculate Volume or Area for object with modifier.
Dec 5 2018, 3:43 PM · Add-ons
Lissanro Rayen (Dragon.Studio) created T58798: 3D Print Toolbox fails to calculate Volume or Area for object with modifier.
Dec 5 2018, 3:40 PM · Add-ons