Geometry Nodes: Rename grid output UV attribute

During review of D10730 it was discovered that the "uv" name causes
issues for cycles, which uses it as a default internal data name. While
that could be fixed in the future, there was no particular reason to use
"uv" instead of "uv_map", so we use the latter instead here, which
is consistent with the lowercase naming scheme chosen for attributes.
This commit is contained in:
Hans Goudey 2021-04-07 13:23:32 -05:00
parent 22ba85b510
commit 1a8db9ec04
1 changed files with 1 additions and 1 deletions

View File

@ -48,7 +48,7 @@ static void calculate_uvs(
MeshComponent mesh_component;
mesh_component.replace(mesh, GeometryOwnershipType::Editable);
OutputAttributePtr uv_attribute = mesh_component.attribute_try_get_for_output(
"uv", ATTR_DOMAIN_CORNER, CD_PROP_FLOAT2, nullptr);
"uv_map", ATTR_DOMAIN_CORNER, CD_PROP_FLOAT2, nullptr);
MutableSpan<float2> uvs = uv_attribute->get_span_for_write_only<float2>();
const float dx = (size_x == 0.0f) ? 0.0f : 1.0f / size_x;