Cleanup: Improve variable name

The new name makes more sense in non-node-related contexts.
This commit is contained in:
Hans Goudey 2022-07-07 08:13:11 -05:00
parent e3ef56ef91
commit 5c3dc52536
2 changed files with 8 additions and 4 deletions

View File

@ -46,7 +46,7 @@ void template_breadcrumbs(uiLayout &layout, Span<ContextPathItem> context_path);
void attribute_search_add_items(
StringRefNull str,
bool is_output,
bool can_create_attribute,
Span<const nodes::geometry_nodes_eval_log::GeometryAttributeInfo *> infos,
uiSearchItems *items,
bool is_first);

View File

@ -50,7 +50,7 @@ static bool attribute_search_item_add(uiSearchItems *items, const GeometryAttrib
}
void attribute_search_add_items(StringRefNull str,
const bool is_output,
const bool can_create_attribute,
Span<const GeometryAttributeInfo *> infos,
uiSearchItems *seach_items,
const bool is_first)
@ -68,8 +68,12 @@ void attribute_search_add_items(StringRefNull str,
}
if (!contained) {
dummy_info.name = str;
UI_search_item_add(
seach_items, str.c_str(), &dummy_info, is_output ? ICON_ADD : ICON_NONE, 0, 0);
UI_search_item_add(seach_items,
str.c_str(),
&dummy_info,
can_create_attribute ? ICON_ADD : ICON_NONE,
0,
0);
}
}