CMake: cleanup, rename INC_HD_CYCLES to SRC_HD_CYCLES_HEADERS

Our convention is to use `INC_*` for include directories,
this caused `make check_cmake` to incorrectly fail as it expected
these files to be include directories.
This commit is contained in:
Campbell Barton 2022-08-27 14:08:28 +10:00
parent 3cba80039d
commit bfca876c05
1 changed files with 3 additions and 3 deletions

View File

@ -21,7 +21,7 @@ set(LIB
)
cycles_external_libraries_append(LIB)
set(INC_HD_CYCLES
set(SRC_HD_CYCLES_HEADERS
attribute.h
camera.h
config.h
@ -75,7 +75,7 @@ endif()
if(EXISTS ${USD_INCLUDE_DIR}/pxr/imaging/hgiGL)
add_definitions(-DWITH_HYDRA_DISPLAY_DRIVER)
list(APPEND SRC_HD_CYCLES display_driver.cpp)
list(APPEND INC_HD_CYCLES display_driver.h)
list(APPEND SRC_HD_CYCLES_HEADERS display_driver.h)
endif()
include_directories(${INC})
@ -83,7 +83,7 @@ include_directories(SYSTEM ${INC_SYS})
add_library(cycles_hydra STATIC
${SRC_HD_CYCLES}
${INC_HD_CYCLES}
${SRC_HD_CYCLES_HEADERS}
)
target_compile_options(cycles_hydra