Page MenuHome

Render resolution affects the size of a mask in the compositor.
Closed, ArchivedPublic

Description

When adjusting the render resolution percentage, masks in the compositor are affected in scale. These should not be tied together.

Here's an animated gif demonstrating..

Details

Type
Bug

Event Timeline

if the animated gif won't load, check out the gif here..

http://www.giphy.com/gifs/l2JhONGhmXbzdvOLu

Hmm, this is intended behavior but for example, the mask node has the Size property to change how this works.

Just curious why this would be the intended behavior? Isn't the render percentage only supposed to modify the final output? By having it affect the way the compositor works, you have to adjust your mask nodes every time you adjust the final render output. This seems cumbersome and unintuitive.

If it were consistent, then all nodes should be affected by this render percentage value. But they're not (nor should they be, imo).

Here, the problem is not the mask.
It is the image.

If you change render output percentage, you have to add a scale node after Image Input and to change its space from Relative to Scene Size or Render Size.

Problem does not exist with a renderlayer node when it is refreshed.

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

Masks are stored in the normalized space (coordinates 0 to 1) which are then mapped to the "canvas". By default, we map them to scene resolution, so when you do alpha-over or things like that in compo you always have same result regardless of render percentage.

If you don't want that behavior, switch mask to a fixed size.

Hey Sergey,

So it looks like the actual bug is that the viewer node doesn't update correctly based off render resolution.. the user is forced to to do a full re-render. This can be very confusing!

I'll log that bug instead.

cheers,
Jason

Hrm, yeah that's confusing.

Do you mind submitting that report with corresponding title and description? (so we don't "reuse" this report to keep it all clear what exact issue we've discussed and such).

happy to - and already did. :)
T50212

woot!