Page MenuHome

Depsgraph does not update
Closed, ArchivedPublic

Description

System Information
Windows 8.1, nvidia Geforce 920M

Blender Version
Broken: (2.79, 5bd8ac9)

Short description of error
This is a follow-up for bug #T53991
The driver for "ScaleX" does not update when "Driver Source" is altered
As stated by Sergey, it has something to do with "Depsgraph missing updates"

Exact steps for others to reproduce the error
Add a cycles material, create a driver in the node editor that takes input from any node variable within that material that uses the new dependency graph.


Attached example is attempting to control ScaleX using the variable input node, using the dependency graph.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.Feb 5 2018, 5:51 PM

You have to run Blender with new dependency graph (--enable-new-depsgraph) command line argument. With new dependency graph the attached file works fine to me.

This is not possible to make this file to work in old dependency graph. In fact, we got rid of old dependency graph in blender2.8 branch already.

What i meant by "missing depsgraph updates" was more like "missing relations in dependency graph update". What that means in practice, is that due to more granular nature of new dependency graph, more edits in interface requires relations to be updated. Rarely, but this is still happening. In order to catch this class of errors you need to save file and re-load it. If that makes tihngs to work, this will indicate that some edit did not tell depsgraph that relations needs to be updated.

So, how do i make this file to fail with new dependency graph?

MWire (MWire) closed this task as Archived.Feb 7 2018, 4:12 PM
MWire (MWire) claimed this task.

I didn't know that, I assumed that it was already enabled by default.