Page MenuHome

OpenCL error when trying to render with Vega 64
Closed, ResolvedPublic

Description

System Information
Windows 10 Home, RX Vega 64

Blender Version
2.79b hash: f4dc9f9d68b (newest official)

When trying to render with my gpu (amd Vega 64) I am getting following error: CL_MEM _OBJECT_ALLOCATION_FAILURE in clCreatorBuffer

Exact steps for others to reproduce the error
Just open the file and render using gpu

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Seems like the file is missing?

Sorry - here is the file.

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Nov 11 2018, 10:33 AM

OK, file is here

@Piotr (arcman) Hi, just to be sure that it is not an out of memory issue. can you try to render it with Simplify texture limit set to 1024?

Thanks

This comment was removed by Piotr (arcman).

@Jeroen Bakker (jbakker) With Simplify texture limit set to 1024 the rendering works just fine (in case of this file). In the meantime It appeared that there is a problem with rendering a pocket studio splash (attached). When rendering with simplify texture limit set to 1024 I am getting an error: cl_out_of_resources clenqueuendrangekernel
With simplify turned off I am getting a cl mem object allocation failure in clcreatebuffer error.

@Piotr (arcman) Not expected. Can you add your system info and clinfo to this ticket. Will try to confiscate a Vega64 here and see if I can reproduce the issue.

Bastien Montagne (mont29) triaged this task as Normal priority.Mar 12 2019, 11:43 AM

I can render both files on my Vega 64.
Full system specs: Here

Sorry for late response. I changed my whole system (expect gpu) an now everything works fine. Prior issues where probably due to the gpu drivers or some incompatibility within hardware (intel i7 3770k). Current system: chipset Z390, i7 8700, 32GB RAM.

Jeroen Bakker (jbakker) closed this task as Resolved.Mar 21 2019, 2:51 PM

Ok, closing issue. If in the future it is not working anymore, you can create a new bug report.