Page MenuHome

Bug OCIO: Cannot find display colorspace when adding a new scene
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX 1080

Blender Version
Broken: Last 2.79 from buildbot 08 march 2019
Worked: 2.79b

Short description of error
With last Open Color IO lib, when we add a new scene, the right color management settings seems not detected correctly.

Exact steps for others to reproduce the error

  • open last 2.79 from buildbot.
  • add a new scene
  • add a cube
  • add a new material

-> the console displays an error message: "OpenColorIO Error: DisplayTransform error. Cannot find display colorspace, ''."
-> when you look at color management settings, it seems there is an issue:

whereas in the main scene it seems configured correctly:

I don't know if the error is caused by a new version of OCIO or changes in Blender.

Backtrace in debug builds:

Details

Type
Bug

Event Timeline

Note: The same bug has already been reported and fixed here: https://developer.blender.org/T56147 but it seems it happens again

those fixes went into master, not into 2.7

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

@Sergey Sharybin (sergey) I guess we would want to backport those patches?

once of them is a workaround for a problem in ocio, which landed the fix last week, we could just wait it out for a new ocio release and update i suppose?

I think the land happened more in past than a last week?
One thing i've been asked about is to finish the fix before the upcoming release. But one thing i didn't check yet is whether the release was actually has been done already.

yeah misread the last line in the pull was a commit from feb24, but the actual commit was jan 29 . no releases have been done since then though.

Sergey Sharybin (sergey) closed this task as Resolved.Mar 11 2019, 11:34 AM

Well, then we can not update OCIO yet, so i just backported the commits to 2.7 branch.
Fixed builds will be available after next round buildbot.