Page MenuHome

Outliner: Impossible hiding / unhiding whole hierarchy including children
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: GEForce 1080 Ti

Blender Version
Broken: 2.80, e8daa615704b, beta, 2019-04-30
Worked: 2.79

Short description of error
Using the outliner of blender 2.79 and pressing on a parent object of an hierarchy in combination with CTRL+CLICK hides the whole hierarchy, including the children. Doing the same again unhides the complete hierarchy.

This is not working in Blender 2.8. Instead you can only isolate an object. But de-isolate is NOT working when clicking on the same object again. Hiding a whole hierarchy in 2.8 is impossible currently or I didn't found it yet.

This is really annyoing when working with a lot of object hierarchies in a scene. Please correct this.

Sometimes I don't understand why you are changing a really optimised shortcut system like it is in v2.79. But I have hope for the future... :)

Exact steps for others to reproduce the error
See my screen capture GIF here:

And here a small example blend file:

Details

Type
Bug

Event Timeline

Not sure what the actual status is here, but this looks like a duplicate of T60159 [which was closed].
There was some discussion in T57857.

Before this gets closed: @Dalai Felinto (dfelinto) : is this still planned to be brought back?

Shift+Click works as far as I can tell, as mentioned in the tooltip. Does that not work?

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.Apr 30 2019, 4:23 PM

@Brecht Van Lommel (brecht): doesnt work for me [also dont see Shift+click mentioned in the tooltip? -- are we all talking about the "eye" icon :) ? -- bit confused now...]

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Apr 30 2019, 4:52 PM

Ah, I was looking at collections, seems to be still missing for parenting hierarchy.

Shift+Click works as far as I can tell, as mentioned in the tooltip. Does that not work?

Shift+Click doen't the job. The hierarchy will not be hidden/unhidden.

CTRL-click hides all objects but the clicked. Anew CTRL+click don't unhides the other objects.

@Brecht Van Lommel (brecht): doesnt work for me [also dont see Shift+click mentioned in the tooltip? -- are we all talking about the "eye" icon :) ? -- bit confused now...]

Yes. The eye icon. :)

@Brecht Van Lommel (brecht): doesnt work for me [also dont see Shift+click mentioned in the tooltip? -- are we all talking about the "eye" icon :) ? -- bit confused now...]

Yes. The eye icon. :)

Ah, I was looking at collections, seems to be still missing for parenting hierarchy.

Please watch the GIF animation in my post and wait some seconds. Later I show it in v2.8. I'm always using "CTRL-click", in v.2.79 too.

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.May 2 2019, 11:23 AM

Implemented on 41858a73111d (only Shift+click, since ctrl+click doesn't make much sense for objects since we already have '/').

Dalai Felinto (dfelinto) closed this task as Resolved.May 15 2019, 12:38 AM

Can we have the same behavior for selecting object hierarchies, please? I mean using the SHIFT key.

How it is currently: Click "CTRL+parent object" -> Select all child objects including parent.
By the way: Anew click on the parent doesn't deselect the hierarchy. Is this willed?

How it could be: Click "SHIFT+parent" -> Selects all child objects including parent.
Anew click "SHIFT+parent" -> Deselects all child objects including parent.

"CTRL+parent object" -> Select all child objects including parent.

That is not the case, only shift does that.

How it could be: Click "SHIFT+parent" -> Selects all child objects including parent.
Anew click "SHIFT+parent" -> Deselects all child objects including parent.

That is how it is implemented. If it does not work can you please open a new bug report and explain how to reproduce it step by step?

And please test with a recent build, after rB41858a73111.

"CTRL+parent object" -> Select all child objects including parent.

That is not the case, only shift does that.

How it could be: Click "SHIFT+parent" -> Selects all child objects including parent.
Anew click "SHIFT+parent" -> Deselects all child objects including parent.

That is how it is implemented. If it does not work can you please open a new bug report and explain how to reproduce it step by step?

Done: https://developer.blender.org/T64662