Page MenuHome

Object texture coordinates not updating in EEVEE
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 660/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.67

Blender Version
Broken: version: 2.80 (sub 71), branch: master, commit date: 2019-05-20 16:16, hash: rB9efe117535c6
Worked: (optional)

Short description of error
When using object texture coordinates with a different object set as source, moving that object relative to the shaded surface does not update the shader in EEVEE until a manual shader change is made (forcing an update) or the scene is rendered. This is only a problem in EEVEE, Cycles works correctly.

Exact steps for others to reproduce the error

  1. Open attached blend file
  2. Switch to rendered mode
  3. Move the "Empty" object relative to the surface and notice that the surface is not updating
  4. Switch to Cycles and move the object again to see correct behavior

Details

Type
Bug

Event Timeline

Sam (Sam200) closed this task as Invalid.May 20 2019, 10:09 PM
Sam (Sam200) claimed this task.

Sorry, this is a duplicate of T57489