Page MenuHome

keyboard layout problems.
Closed, ArchivedPublic

Description

blender 2.8 rc.
windoz X
GTX1060

the issue it's easy to understand.
i have an italian keyboard.

when i try to remap some shortcuts, the keyboard layout doesn't correspond with the italian keyboard.
but it happen ONLY in keymap windows.

Details

Type
Bug

Event Timeline

i can not confirm this bug, on linux any nationalized key as 'è ò ç ù' are not valid to be used for new shortcut

OpenSUSE Tumbleweed linux, AMD FX8350 cpu, 16G ram, Nvidia GTX690 - 430.34, italian 101 key keyboard

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-11 13:50, hash: rB06312c6d2db8

German keyboard also has problems. If I press the german keys ä, ö, ü etc the keys from the english keyboard layout are inserted.

But the same goes for Blender 2.79b:

I don't think this is a bug because there is not an area to enter text, but the name given by Blender to a specific key on the keyboard.
The same key can indicate different symbols depending on special keys like Caps Lock, Num Lock, etc.
Which symbol to choose in these cases?

Maybe that is a translation issue...

@Bastien Montagne (mont29), what do you think?

@Bastien Montagne (mont29), seems to be a multiplatform issue, i recently (relatively speaking) reported the same here:
https://developer.blender.org/T65532

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

This has nothing to do with translation. That’s a basic, long-standing known issue that code was essentially built for English (US) keyboard layout, and that we do not have any kind of support for others. We do have a few hacks here and there for the most common/annoying issues with other layouts (like supporting the top-row numbers also with layouts where you'd need to use Shift to access those), but that’s about it.

Working on this would be a TODO, likely involving rewriting a fair share of our GHOST code to handle inputs in a more abstract way (probably using some OS-specific wrappers, etc.).

I think this should get an entry in the T63726: User Interface Module , but will let their owners (@Campbell Barton (campbellbarton)/@Brecht Van Lommel (brecht)/@William Reynish (billreynish)) decide about it.

In the mean while, since that’s not a bug, will archive the report, thanks.