Page MenuHome

Accessibility: Rigging bone text cannot be resized independently
Confirmed, LowPublicDESIGN

Description

System Information
Operating system: Darwin-20.0.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 575 OpenGL Engine ATI Technologies Inc. 4.1 ATI-4.0.33

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-08-26 21:53, hash: rB479ce00809af
Worked: (newest version of Blender that worked as expected)

Short description of error
Let me show you an example of Rigging on bone text.
The text in viewport here is too small.


So I try to increase Theme > Text style > widget > points.


But it also creates overlapping blocks in the rest of the interface. This is problematic when they cannot be resized by command + two finger scroll (MMB), like in top bar menus.


Changing resolution doesn't work since the menus eat up a lot of space on the screen.

Exact steps for others to reproduce the error
See previous link https://developer.blender.org/T79059

Enable armature names in Object data properties.
Attempt to resize the name of the bone.

Event Timeline

I know you went over this, but can you give example where resolution scale is not enough? Resolution scale should resolve your problem, otherwise it's bug.

Ankit Meel (ankitm) added a comment.EditedAug 28 2020, 9:46 AM

but can you give example where resolution scale is not enough?

When one needs a wide viewport with big text (armature names). Changing resolution also makes the available space in 3d viewport small.

As Kent wrote in an example T79059#981468,
Enable armature names:



Now attempt to increase the size of the word "Bone". I only know one method: by increasing Text style > widget > points.


(I don't know about the code, so it may not be possible)
The requested functionality is for the viewport text size to be editable like in properties panel, N-panel etc: command + two finger scroll.
Another way is to decouple viewport text size from widgets.

Ankit Meel (ankitm) renamed this task from Preferences > Theme > Text Style need height fit without overlap Part 2 to Accessibility: Rigging bone text cannot be resized independently .Aug 28 2020, 10:01 AM
Ankit Meel (ankitm) updated the task description. (Show Details)

I suggest decreasing the limit for maximum text size to 24.

  1. If we talk about UI accessibility. The user must first configure the system, macOS has many features for this.
  2. Then, user can additionally set the resolution scale in Blender, up to 4.00!
  3. Changing the text size does not affect other elements such as icons or gizmo, so it is not for accessibility purposes.
  4. If we increase the button size together with the text size, it will be the same as scaling the entire UI.
  5. All this will not affect the overlapping names of bones/objects in the viewport.

We just did discuss and I found out. Change not talk about Rigging.
Ignore about rigging. I talk about Text Style to show you 4 pictures.
Focus on Properties, Menu, and everything.

Ankit Meel (ankitm) added a comment.EditedAug 28 2020, 11:33 AM

Change not talk about Rigging.
Ignore about rigging. I talk about Text Style to show you 4 pictures.

What is the motivation/ need to change the text size to this high ?

Sighyou still don't understand 4 pictures.

I think you need Interface Scale, not text size.

As mentioned before, it might be nice to limit the text size at the size that the UI can handle, or not let it be customized independently at all. But having too much freedom is hardly a bug.

It also would be nice to add a property for specifically bone name display size, but that's a feature request and doesn't belong on the bug tracker. It would be a bug if bone name display size didn't change with the resolution scale, but it does. I don't think there's a bug here, so closing for now.

Demeter Dzadik (Mets) closed this task as Invalid.Aug 28 2020, 12:51 PM
Demeter Dzadik (Mets) claimed this task.

You still stubborn make me mad! You ignore me as well and you are hate me!
You still ignore me as well what focus Text Style. I am not talk about Interface.
Focus on Text Style code to fix height!
I believe you REJECT me.

Unfortunately we have strict definitions for what a bug is. A bug is a behaviour that's not working as the developers intended. A bug is NOT a feature that's not working as the user expected. I just don't see a bug here. Feature requests should go to https://blender.community/c/rightclickselect/.

I am still curious though, Where resolution scale is not enough? Why you insist on fixing text style? There may be design implication we are not aware of but we don't understand it.

Though I would agree handling this issue on tracker is not the best option.

@Richard Antalik (ISS) yes and I read your message so I take video record on my iPad Pro and upload to youtube so you can see.
I do sign language. I am full deaf. I don't speak voice.
https://youtu.be/5lSP_T_2gBw

@Kent Davis (mac4kent) Is there a reason you can't do this? To again reiterate, this will help negate the issues you're having.
Still haven't see you push the resolution scale past 2.00...

@Kent Davis (mac4kent) Show me you have done what I said in my original comment.

You can get to this by doing that:

Christopher_Anderssarian ignore about rigging. I show youtube last one
I see (View) menu list

If I understand correctly, controls are OK with resolution scale = 2, but you still want text to be larger.

I can see how this helps you, but this would be significant change that needs proper design. It would be more a project to work on than a bug.

@Richard Antalik (ISS) did you see I do sign language to show you?

Sorry, my comment should be question. I just wanted to confirm if I undesrstand you correctly.

@Richard Antalik (ISS)
I am not good english to explain text only.
ICON = Stay is the same no change scale. See youtube of (Text Style)
Text = Can do Text Style.
Make sure to fix height to be fit without overlap.

If I understand the issue correctly, increasing the DPI a lot is not an option, because it leaves too little space to work with. So to get the viewport fonts big enough, the theme's text style settings are used, but doing so makes the text elsewhere larger than the buttons.
Maybe we should have a separate text style in the theme for viewport text. I wouldn't be opposed to it, so if somebody wants to create a patch for it, feel free.

Besides that, I think limiting the point size like @Yevgeny Makarov (jenkm) proposes makes sense.

Oh well I talk about text style this button must to fix code height to be fit. I send picture already.

Oh well I talk about text style this button must to fix code height to be fit. I send picture already.

@Yevgeny Makarov (jenkm) 's patch D8749 will fit the text in the box without overlap. Julien is not opposed to that.

+1, I want to increase the size of only the bone names. I don't want to change UI scale or DPI because that will make everything bigger. Especially with Japanese letters, they can be too small to read sometimes.

@Rena Kunisaki (renakunisaki) yes I agree with you. Text Style need to fix code also Japanese.

I don't actually think that what Kent is wanting is really addressed in this Text Style area.

In fact what he is specifically asking for (that text boxes increase in vertical size so that they can contain the text when made larger, without increasing everything else using UI scale) could be addressed by just adding a separate "Icon Size" slider next to "Resolution Scale". In that way you could have larger text without having huge icons as well.

But I think fundamentally what he needs is to have more - not sure what we call it exactly - local 2D zooming...

Right now I can ctrl-Middle mouse drag to increase the size of the contents of the Properties area. That is a start, but it would better if I could also do same for the tabs area in Properties. Or anywhere in the Outliner. And everywhere else.

Inside the 3D viewport we can do so for the Toolbar and for the Sidebar. But it would be better if we could also do so for the navigation gizmo, the "redo" panel, and the the overlay and other text displayed inside this editor. It might even be nice to do so for headers.

Ankit Meel (ankitm) reopened this task as Confirmed.Sep 3 2020, 9:12 PM
Ankit Meel (ankitm) removed Demeter Dzadik (Mets) as the assignee of this task.
Ankit Meel (ankitm) triaged this task as Low priority.

As it was also mentioned in https://devtalk.blender.org/t/2020-08-31-ui-team/15106/1 under other topics, reopening.
Sorry Kent for taking over your bug report. The original report T79059 is resolved, and this one will be used for viewport text styles.

Hans Goudey (HooglyBoogly) changed the subtype of this task from "Report" to "Design".Sep 8 2020, 5:59 PM

Since the proper solution here is not clear (and the specifics of the problem aren't super clear either), I'm classifying this as a design task.

I definitely think Blender developers have been treating UI scale as the generalized answer to these accessibility concerns. I guess that's not the best option for everyone.
But if it's agreed that isn't the solution, we should decide what the proper solution is.

I like @Harley Acheson (harley)'s idea about being more consistent about local 2D zooming. As an example of my last point though, local middle mouse button zooming was recently disabled
in the redo panel to solve a bug. (Don't remember the commit, but it's an example of the haphazard design around those sorts of features.)