Page MenuHome

Menu search behaves differently when opened from menu
Closed, ArchivedPublic

Description

System Information
Operating system: macOS 10.15.7
Graphics card: AMD Radeon Pro 5300M

Blender Version
Broken: Version 2.91.0 (2.91.0 2020-11-25)

Short description of error
Menu search (F3) displays different results when opened from the menu vs hotkey. This is only noticeable with developer tools off. When they are off opening the menu search tool by clicking through the menu seems to display operators that normally would only be available with developer tools turned on.

Exact steps for others to reproduce the error

  1. Make sure developer tools are turned off
  2. Follow tutorial from to add a new python operator https://docs.blender.org/api/current/info_quickstart.html#example-operator
  3. Press F3, and type simple, the operator should not display (this seems be the intended behavior according to https://developer.blender.org/T76227
  4. Open menu search from the menu note the operator appears when searching for it

Event Timeline

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.Dec 27 2020, 2:49 PM

I only see the template Text Editor: Templates > Python > Simple Operator when the Developer Extras are disabled. Could you please check if that is the same entry you're seeing?

Ahh your right maybe that is what was confusing me. Sorry to waste your time then.

Weirdly I don't see the text editor templates when using the hotkey F3 in developer mode, just the operator.

Feel free to close this!

Robert Guetzkow (rjg) closed this task as Archived.Jan 8 2021, 3:34 PM

It depends on where you mouse cursor is when you press F3. If you do this while it is in the text editor it should show you the templates as well.